Požadavky na systém

JOGL pro svůj běh vyžaduje operační systémem Linux, MacOS, Solaris nebo Windows. Počítač by měl být dostatečně výkonný pro provoz Javy verze 1.4.2 a vyšší. Další nároky na software a hardware jsou pak závislé na konkrétní aplikaci.

U jednoduchých 3D scén bude stačit obyčejná grafická karta, která hardwarově podporuje pouze OpenGL 1.2. Náročné aplikace mohou vyžadovat hardwarovou podporu OpenGL verze 2.

V ideálním případě by měl být aktualizovaný operační systém, nainstalovány nejnovější ovladače pro grafickou kartu. Totéž platí o Javě, JOGL a případně i o dalších používaných rozšiřujících třídách, jakou může být například OpenAL.