Uživatelská dokumentace

Systémové požadavky a spuštění

K běhu 3D Bludiště je vyžadováno JRE 1.5 a JOGL 1.1. Program se spouští souborem 3dmaze.jar. Pokud je na počítači nainstalovaný JOGL, aplikace se spustí a uživatel může procházet bludištěm. V případě, že JOGL nainstalovaný není nebo je nainstalována nekompatibilní verze, je nutné při spuštění specifikovat cestu ke knihovnám, které jsou přidány k programu. Bludiště se pak spouští následujícím příkazem:

java -Djava.library.path=./lib/windows -jar 3dmaze.jar

kde ./lib/windows je cesta ke knihovnám, které přísluší vašemu operačnímu systému. Pro zjednodušení spouštění jsou ke stažení spouštěcí skripty pro Windows a Linux. Uživatel si tedy nemusí pamatovat výše uvedený příkaz. V Linuxu bude pravděpodobně nutné přiřadit souboru práva na spouštění příkazem:

chmod +x linux_start.sh

Ovládání

Program nabízí velice jednoduché ovládání. Hráč se po bludišti pohybuje pomocí níže uvedených kláves a pomocí myši se může rozhlížet po okolí.

Pohyb po bludišti

Wdopředu
Adoleva
Sdozadu
Ddoprava

rozhlížení po okolí je uskutečněno pomocí myši

Další klávesy

Lzapne/vypne světla
Fpřepne filtr textur
~konzole
Esckonec

Shrnutí

3D Bludiště jsem primárně vyvíjel a testoval na notebooku s Pentium M 750, Mobility Radeon X700, Windows XP SP2 a Java 1.6.0-b105. Testování probíhalo na odlišných verzích Windows a různých distribucí Linuxu. Zkoušel jsem odlišné Javy od verze 1.5 až po 1.6. Java starší než 1.5 není podporována, protože využívám typované kolekce.